CCProxy Help

CCProxy主要功能和特点

  • 设置简单，功能强大，完全支持 Win98/WinMe/WinNT/Win2000/WinXP/Win2003。
  • 支持共享Modem、ISDN、ADSL、DDN、专线、蓝牙、二级代理等访问Internet。
  • 支持HTTP、FTP、Gopher、SOCKS4/5、Telnet、Secure(HTTPS)、News(NNTP)、RTSP、MMS等代理协议。
  • 支持浏览器通过HTTP/Secure/FTP(Web)/Gopher代理上网。
  • 支持客户端使用Outlook、Outlook Express、Foxmail等通用邮件客户端软件收发邮件。
  • 支持OICQ、ICQ、Yahoo Messenger、MSN、iMRC、联众游戏、股票软件通过HTTPS、SOCKS5代理上网。
  • 支持CuteFTP、CuteFTP Pro、WS-FTP、FXP-FTP等FTP软件通过代理上网。
  • 支持RealPlayer通过RTSP代理接收视频，支持MediaPlayer通过MMS代理接收视频。
  • 支持NetTerm通过Telnet代理上网。
  • 支持Outlook通过News代理连接新闻服务器。
  • 支持远程拨号、自动拨号、自动断线、自动关机功能。
  • 支持二级代理，可以使代理服务器通过其他代理服务器上网。
  • 双击界面上的绿色网格可以实时观测代理用户连接信息。
  • 简单实用的帐号管理功能，可以针对不同用户定义不同的上网限制。
  • 帐号管理支持IP段设置方式和自动扫描帐号功能，建立帐号更轻松。
  • 支持多种方式的帐号认证方式和混和应用：IP地址、MAC地址、用户名密码、域帐号管理。
  • 支持HTTP和SOCKS5用户验证。
  • 内置域名解析功能DNS。
  • 时间管理功能：可以自由控制不同用户的上网时间。
  • 网站过滤功能：可以屏蔽特定网站和内容，也可以限定用户只能上指定的网站。
  • 缓存功能：可以自由设定缓存大小，更新时间，提高访问速度。
  • 带宽控制：可以灵活的控制每个客户端的上网速度。
  • 支持WinNT/Win2K/WinXP/Win2003下以NT服务运行方式。
  • 其他高级功能：加载代理广告条、启动时拨号、端口映射、流量计费等，具体用法参加主页和论坛。

购买CCProxy


安装说明


代理服务器硬件和软件基本要求

1) 服务器的配置跟用户数有关。
如果用户数在20人以内，一般的PC电脑就可以作为代理服务器了。推荐PII芯片，内存128M，硬盘10G。如果用户数在20人以上100人以下，需要选用专业的服务器作为代理服务器，服务器一定要专用，即专门作为代理服务器来用。推荐PIII芯片，内存256M，硬盘20G。如果用户数在100人以上，需要选择高配置的服务器作为代理服务器，服务器一定要专用，即专门作为代理服务器来用。推荐双CPU，内存1G，硬盘40G。
2) 网卡配置。
尽量选用性能比较稳定的网卡作为服务器网卡，100M网卡。推荐品牌：原装D-Link，3COM。由于是作为服务器网卡，尽量选用高性能中高价位的网卡。
3) 操作系统。
如果客户端用户数在10人以上，我们推荐您安装Win2000 Advanced Server，并打好最新补丁。Win98只适合10用户网络环境，Win NT需要打太多的补丁，Win2000 Professional只适合个人和家庭电脑，所以最好选用Win2000 Advanced Server。
4) 杀毒软件及防火墙软件。
我们推荐您用Norton杀毒软件及Norton防火墙软件来保护您的服务器。为了方便调试代理服务器，请在代理服务器安装调试成功后，再安装和使用杀毒软件和防火墙软件。


局域网网络环境配置要求

确认局域网连接通畅，能够相互ping成功。
服务器的IP设置有几个需要注意的地方：
1) 检查服务器的网络属性，确保里面没有多余的无用的TCP/IP协议，如果服务器是Win98操作系统，操作系统安装过程中会自动添加一些无存在的拨号适配器及相应的TCP/IP协议，需要删除这些多余的网卡适配器和相应的TCP/IP协议。否则很容易引起网卡冲突。
2) 如果服务器安装了两块网卡或者多块，在网卡IP设置上需要注意，不要将网卡的IP设置在一个网段内，这样会造成路由混乱。比如一块网卡是192.168.0.1，另一块网卡就不要设置成192.168.0.2，可以设置为192.168.1.1。
3) 服务器的网卡一般不要设置网关，尤其是连接局域网的网卡，不要设置网关，否则很容易造成路由冲突。

如果没有配置好局域网，建议按照下面的方法配置局域网。分配好局域网机器的IP。一般是192.168.0.1、192.168.0.2、192.168.0.3、…192.168.0.254，其中服务器是192.168.0.1，其他IP地址为客户端的IP地址。子网掩码为255.255.255.0，DNS为192.168.0.1。如果客户端操作系统是Win98，请设置网关指向192.168.0.1，DNS主机名填本地机器名。


互联网接入方式的要求

目前已知的互联网接入方式中，代理服务器CCProxy大部分都支持。ADSL拨号用户(非网卡直连用户)需要注意的是，由于有些电信自带的ADSL拨号驱动程序很陈旧，请到我们网站的下载页面下载新的ADSL拨号驱动程序，以便更稳定的与互联网保持连接。


缺省代理端口列表

HTTP: 808 - 用于浏览器上网
FTP (Web): 808 －用于浏览器连接FTP站点
FTP: 2121－用于FTP客户端软件连接FTP站点(如CuteFTP)
Gopher: 808－用于浏览器连接Gopher站点
Secure/SSL/HTTPS: 808 －用于浏览器连接安全站点
RTSP: 808－用于Real Player
SOCKS: 1080－用于部分网络客户端软件(如QQ，联众)
MMS: 1080－用于Media Player
News (NNTP): 119－用于Outlook连接新闻服务器
SMTP: 25－用于邮件客户端软件发送邮件(如Outlook，Foxmail)
POP3: 110－用于邮件客户端软件接收邮件(如Outlook，Foxmail)
Telnet: 23－用于某些Telnet客户端软件，如(CTerm)


安装中常见的启动失败问题


DNS启动失败

有两种可能：
1) 服务器上安装了其他代理服务器软件。这时需要停用其他代理服务器。
2) 服务器缺省安装了Windows自带的DNS服务器。这种情况一般多发生在Win2000上。
因为Win2000已经自动安装了DNS服务器，无需使用CCProxy的DNS服务，可以取消CCProxy的DNS代理：“设置“ -> 取消"DNS"选项。


邮件代理启动失败

这是因为你的服务器上安装了其他跟邮件服务有关的程序，造成冲突。有很多原因造成这种现象：
1) 如果你安装了可以防止Email病毒的杀毒软件，可能会造成110(POP3)端口冲突，这时你需要修改杀毒软件的端口(并不是所有的杀毒软件可以修改端口，瑞星杀毒支持修改端口)。如果不能修改， 就只好停用这项杀毒功能。虽然CCProxy提供了修改POP3端口的功能，但是我们不建议你这样做，因为会导致大量客户端程序跟着修改端口。优秀的杀毒软件Norton不会有这种现象。
2) 如果你安装了其他代理服务器软件，可能会造成110(POP3)，25(SMTP)端口冲突。因为有些代理服务器可能也具备邮件代理功能。这种情况下，你需要停止这些代理服务器中的邮件代理功能。
3) 如果你安装了防火墙程序，也可能会造成端口冲突。需要开放25(SMTP)、110(POP3)、53(DNS)、80(HTTP)、8011(Admin)、5353(MX)端口。
4) 如果你安装了邮件服务器程序，也会造成端口冲突。原因是很明显的，都用了相同的端口。你必须停止这些邮件服务器才能使CCProxy运行正常。
5) 如果你能确认其他软件也能完成邮件代理功能(如CMailServer)，那么你可以不必再用CCProxy的邮件代理了，从“设置”里取消“邮件代理”。

一个很简单的测试本机是否安装了其他跟邮件有关的软件的方法：在命令行方式下，输入命令 telnet 127.0.0.1 110 或者 telnet 127.0.0.1 25，你就可以看到相应的提示信息判断出跟哪个软件有关。


新闻代理服务启动失败

有两种可能：
1) 服务器上安装了其他代理服务器软件。这时需要停用其他代理服务器。
2) 服务器上安装了微软的NNTP Service，这是需要停用NNTP服务。
从控制面板->添加/删除程序->添加/删除windows组件->Internet信息服务(IIS)->NNTP Service。 取消NNTP服务。


SOCKS或者HTTP等代理启动失败

出现这种问题，主要是因为您的机器已经安装了其他代理服务器软件，造成冲突。
解决办法是停用这些软件或者修改CCProxy的代理端口(在CCProxy设置对话框里可以修改)。


客户端设置说明

客户端是指需要通过代理服务器上网的机器。客户端不需要安装CCProxy。
常见软件的设置请看主页上的图例 。


客户端设置前的准备工作

1) 确认客户端与服务器是连通的，能够互相访问。
2) 确定代理服务器地址。代理服务器地址就是安装代理服务器的机器的网络地址。
这个地址，是指服务器在局域网中的本地IP地址。本地IP地址可以从CCProxy的设置对话框中得到。
设置对话框中的本地IP地址一般情况下可以用"自动检测"得到。如果服务器安装了双网卡，则需要手工选取：取消"自动检测"，从列表中选取。
如果不能确认服务器的IP地址，也可以用服务器的机器名作为代理服务器地址。


设置IE浏览器代理上网

IE浏览器->菜单“工具”->“Internet选项”->“连接”->“局域网设置”->选中“使用代理服务器”->“高级”->“代理服务器设置”。
取消"对所有协议均使用相同的代理服务器"；
在“HTTP”中填上代理服务器地址，端口为808；
在"Secure”中填上代理服务器地址，端口为808；
在“FTP”中填上代理服务器地址，端口为808；
在“Gopher”中填上代理服务器地址，端口为808；
在“Socks”中填上代理服务器地址，端口为1080。
请看主页上的图例


设置Outlook的邮件代理

请看主页上的图例


设置Foxmail邮件代理

请看主页上的图例


设置Outlook新闻代理

选择你已经配置好的新闻服务器，右键菜单->属性->服务器，
假设你原来的服务器名为msnews.microsoft.com，现在将服务器名改为代理服务器地址，
选择“此服务器要求登录”，在帐号里面填上 #msnews.microsoft.com，密码空缺，
在“记住密码”前打勾.
需要注意的是，如果您上的不是免费的新闻服务器，也就是要求您提供帐号和密码的，
那么您的帐号名应该修改为：旧的帐号名#原新闻服务器地址，密码还是原来的密码。


设置CuteFTP代理

菜单 Edit -> Settings -> Connection -> Firewall:
Host 后面填代理服务器地址，端口2121， Type选择“USER user@site”，在“Enabel firewall access”前打勾。
菜单 Edit -> Settings -> Connection -> Socks -> Use direct connection.


设置CuteFTP Pro代理

菜单“Edit”->“Global Settings”->“Connection”->“SOCKS4 & 5”:
选择“Use the highlighted Socks server when connecting.”;
选择“Add”按钮，删除Host里的“<New>”，填上代理服务器地址，Port填1080。
不要选“Use Authentication”，选择“Socks5”。


设置ICQ代理

ICQ-> Preferences -> Connections:
"Server" : 选择"Using Firewall", "Proxy" 选择"Socks 5"
"Firewall" : 选择"Socks 5", 在"Host"里填写代理服务器地址，"Port" 填1080,
选择"use proxy to resolve hostnames"
详细设置图请看http://www.youngzsoft.com/tools/icq.htm (假设代理服务器地址为192.168.0.1)


设置MSN Messenger代理

菜单"工具"->"选项"->"连接":
选择"我使用代理服务器"，类型选择SOCKS 5，服务器填本地代理服务器的IP地址，端口1080，其他不填。


设置OICQ代理

在OICQ的系统菜单里选择“系统参数”->OICQ参数设置->网络设置, 将上网类型设置为“局域网接入Internet”， 选择“使用PROXY SOCKET5防火墙”，防火墙地址填上"代理服务器地址"，端口填上1080。 完成设置后按“测试”按钮，如果测试正常，表明代理设置成功。
请看主页上的图例 。


设置网络蚂蚁代理

菜单“Option”->“Preferences”，弹出设置对话框，选择“Proxy”一页，在列表框里选择“Direct connection”，取消“Default for HTTP”和“Default for FTP”选择，点击“Add”，在“Name”填上CCProxy，“Addr”填上代理服务器地址，“Port”填上1080，“Type”选择Socks5，确定，选择刚刚添加的“CCProxy”，选择“Default for Http”、“Default for FTP”和“User default proxy for all jobs”，确定。


设置网际快车FlashGet代理

“工具”->“选项”->“代理服务器”->“添加”，在名称里写上CCProxy，类型选Socks5->“确定”->在“CCProxy”一行的“Http缺省”和“Ftp缺省”两列打勾，在“所有的任务均使用缺省的代理服务器”前打勾。


设置联众游戏代理

运行联众游戏，弹出“选择连接站点”对话框->“设置代理服务器”: 在“通过代理服务器(Proxy)连接Internet”前打勾，在“代理服务器地址”里填上代理服务器地址，端口为1080，选择“使用Socks5协议”，其他为空。


设置客户机联网游戏CS, 石器时代, 三国等代理

这类软件本身没有设置代理的功能，就只能求助于NEC的e-Border，需要在客户端安装e-Border。猎手与蚂蚁收藏馆(该网址可以在google搜索蚂蚁收藏馆)上有完整的NEC e-Border Client 2.11 的解决方法和程序下载。需要注意的是客户端的网络属性 -> TCP/IP属性里一定要设置DNS，地址填代理服务器地址。服务器上的CCProxy设置里要选择DNS服务。e-Border简单设置方法:在客户端安装e-Border Client, 打开e-Border设置界面，在General一页，有三个图标，有一个"Setup Wizard". 点击"Setup Wizard" -> "e-Border Client Setup Wizard" -> 选择 "I want to set up the client" -> 下一步 -> 选择 "I have one server" -> 下一步 -> 在 Name 里填上代理服务器地址，在Port里填上 1080 -> 下一步 ->选择 "Does not require authenication" -> 下一步 -> 选择"Proxy All" -> 完成。注意：客户端要设置DNS指向代理服务器。 具体设置请看主页上的图例。


设置语音聊天代理

大部分的网站提供的语音聊天都没有设置代理的功能，需要在客户端安装SocksCap32，将语音聊天软件或者其载体(IE)加入到SocksCap32里。
详细的设置方法请看 http://www.youngzsoft.com/cn/sockscap


设置NetMeeting代理

NetMeeting没有设置代理的功能，需要在客户端安装SocksCap32，将NetMeeting加入到SocksCap32里。客户端要设置DNS指向代理服务器IP地址，如果是Win98，需要设置DNS主机名为本机机器名。
详细的使用方法请看 http://www.youngzsoft.com/cn/sockscap


设置RealPlayer代理

请看主页上的图例 。


设置MediaPlayer代理

请看主页上的图例 。
完全支持MediaPlayer 7.01 以上版本的MMS代理和HTTP代理。
MediaPlayer 6.4以上版本只支持HTTP代理。


设置NetTerm上BBS站点

菜单“File”->“Phone Directory”。
在列表中选择一项你想连接的BBS。比如bbs.execpc.com。
这时下面的信息显示为：Host Name为bbs.execpc.com，Host/IP为空，Telnet Port为23。
在Host/IP里填写代理服务器地址，就可以了。
单击“Connect”按钮，这时蓝色显示屏上会出现: CCProxy Telnet>CCProxy ...等提示信息，
输入 open bbs.execpc.com，敲“Enter”键，就可以登陆bbs.execpc.com了。
如果不想每次都输入open bbs.execpc.com，你需要在按照这样的步骤来做：
1. 用Notepad编辑一个文本文件。
如果登陆bbs.execpc.com，文本的内容为：
output "open bbs.execpc.com ^M"
如果登录bbs.tsinghua.edu.cn，文本的内容为：
output "bbs.tsinghua.edu.cn ^M"
2. 将这个文件保存到NetTerm的安装目录。
3. 打开“Phone Directory”对话框里选择对应的登陆服务器，选择“Select Logon Script”，
“Select”刚才保存的文件， 点击“OK”。


设置聊天室代理(基于Java)

因为这类聊天室是用java写的(如网易聊天室 chat.163.com)，需要设置java虚拟机的socks代理，可以通过
http://www.youngzsoft.com/tools/setjavaproxy.html 来设置java虚拟机的socks代理。 要选择代理服务器设置里的"DNS"，客户端的DNS要指向服务器IP地址。


设置Norton Antivirus在线更新病毒库代理

首先在IE里设置好http代理，打开Norton Antivirus的LiveUpdate，弹出“Live Update”对话框，单击对话框上的"Configure..."按钮，弹出“Liveupdate Configuration”对话框，在“ISP”选项卡里选择第一项"the Internet Options ..."，在“Proxy”选项卡里选择第三项"I want to use my Internet Explorer ..." 。


设置金山毒霸在线升级代理

菜单“工具” -> “升级设置” -> 选择“使用socket5代理服务器” -> “设置...”-> “服务器地址”填代理服务器地址 ->“端口”填1080


其它软件的代理设置

1) 参考主页上最新公布的客户端软件设置方法。
2) 如果这些软件本身有代理设置选项(一般在网络设置或者系统设置里)，就可以参照相应协议和端口进行设置。
3) 如果这些软件本身没有代理设置，可以在客户端安装NEC公司SocksCap32，将这些软件加入到SocksCap32里。
SocksCap的具体设置方法和下载地址请看http://www.youngzsoft.com/cn/sockscap


帐号管理

详细内容请看主页上的帐号管理。


帐号管理基本概念

代理服务器CCProxy的帐号管理分为三个部分。分别是允许范围，验证方式和帐号设置。

允许范围有三种选择: 允许所有，允许部分和不允许部分。
允许所有是缺省状态，表示允许所有客户端上网，此方法适用于不需对客户端进行上网管理的应用。
允许部分表示只有加入用户列表的用户可以上网，并可以实现对用户进行各种管理。
不允许部分表示只有加入用户列表的用户不允许，其他都允许。

验证类型有六种选择，此选项用来设置缺省帐号管理方式，编辑单个用户还可以对单个用户采用特别的帐号管理方式。
1) "IP地址"是指用户的身份通过IP地址来验证;
2) "MAC地址"是指用户的身份通过MAC地址(网卡的物理地址)来验证;
3) "用户/密码"是指用户的身份通过用户名和密码来验证;
4) "用户/密码+IP地址"是指用户的身份通过用户名、密码和IP地址三者同时来验证;
5) "用户/密码+MAC地址"是指用户的身份通过用户名、密码和MAC地址三者同时来验证;
6) "IP+MAC"是指用户的身份通过IP地址和MAC地址同时验证。

帐号设置:
"新建": 可以新建一个帐号。
"编辑": 可以修改一个帐号。
"删除": 可以删除选中的帐号。
"全选": 选中所有的帐号。
"自动扫描": 这个功能是方便管理员初始化帐号信息的，当第一次设置帐号的时候，管理员可以打开所有的客户端机器，输入起始IP地址和结束IP地址，然后单击"开始"，可以自动获取局域网里所有客户端机器的IP地址、MAC地址和机器名。


新建帐号说明

"帐号" -> "新建"
"用户名/组名": 用来标识不同的帐号。
"密码":用来设定客户端上网需要的密码。
"IP地址/IP段": 可以是单个IP地址，也可以是IP段。比如 192.168.0.1 和 192.168.0.1-192.168.0.10 都是可以的。当设置成IP段时， 表明这个IP段的用户都共享这个帐号的权限。
"MAC地址": 是指客户端网卡的物理地址。
"最大连接数": 是指客户端允许的最大同时活动的连接数。-1表示不限制客户端连接数。
"带宽(字节/秒)": 是指客户端允许的最大带宽，可以用来限制客户端上网速度。-1表示不限制带宽。
"服务": 可以指定该帐号的允许服务项目。
"网站过滤": 可以选择在"网站过滤"中已经定义好的网站过滤。
"时间安排": 可以选择在"时间安排"中已经定义好的时间安排。


用户名/密码验证方式的说明及注意事项

这种管理方式主要对浏览器上网和SOCKS5代理上网进行用户身份验证。
如果选择了包含"用户/密码"的验证类型，客户端通过浏览器上网时，浏览器会弹出要求输入用户名和密码的对话框，用户名和密码只是在启动浏览器第一次访问网站时需要输入用户名和密码，从已经打开的浏览器里访问新的网站和打开新的窗口不需要再次输入用户名和密码，但是启动新的浏览器访问网站会要求再次输入用户名和密码。通过SOCKS5协议上网的软件也需要在代理设置里填写用户名和密码。如QQ。
注意: 如果要对客户端开放邮件代理，FTP代理，SOCKS4代理等服务，必须结合IP地址、MAC地址等验证方式，或者建立一条新的帐号，采用IP地址或者IP段管理方式来开放其他服务。


如何控制客户端上网速度

控制客户端上网速度需要帐号属性里的两个参数来限制："最大连接数"和"带宽"
"最大连接数"是指服务器同时响应的客户端的最多的连接数，该客户端多余的连接将被代理服务器自动挂起，直到该客户端释放出已经响应的连接。
"带宽(字节/秒)"是指客户端最大的每秒钟的字节流量。

通常情况下，我们可以设置客户端的最大连接数是10个，带宽为10240(即为10K)。如果要严格控制客户端使用网络蚂蚁的情况，可以适当减少带宽或者最大连接数。


网站过滤的说明

网站过滤可以有效的控制客户端访问的网址。
操作："帐号" -> "网站过滤"
可以定义不同的网站过滤规则。"网站过滤名": 输入不同的网站过滤名，用来标识不同的网站过滤规则。
网站过滤分为"站点过滤"、"禁止连接"、"内容过滤"。
注意: 这里只是定义网站过滤规则，如果要应用该网站过滤规则，需要编辑相应的帐号，选择和应用该规则。

站点过滤
在编辑框里，可以输入多个过滤站点，以分号分隔。站点过滤支持通配符(*,?)。
如：*.yahoo.com;???.hotmail.com;www.*.org
如果站点包含多级域名，比如sina，包含了www.sina.com.cn;www.sina.com，应该用*.sina.*.*;*.sina.*来过滤，而不是只用*.sina.*来过滤。
"允许站点"，"禁止站点": 决定过滤的站点是允许访问还是禁止访问。
注意: "站点过滤"中的"允许站点"仅适用于结构简单的站点(如本公司站点)，不适应如163、sina等站点，因为此类站点结构比较复杂，页面中有些图片等信息来自于其他站点，会造成页面显示不全等问题。

禁止连接
在编辑框里，可以输入多个禁止连接内容，用分号分隔。下面是一些参考的例子：
如果要限制客户端下载文件可以用.exe;.zip;.rar;来过滤。
如果要防止客户端用webmail收发邮件，可以用mail;来过滤。
如果要防止客户端上网页BBS聊天，可以用chat;bbs;来过滤。

内容过滤
可以过滤含有特定文字的网页。只要该网页含有特定字符，就可禁止显示该网页。
"内容过滤": 实现此网站过滤的"内容过滤"，可以过滤多个内容，内容之间以分号分隔。如：sex;chat;travel
注意: 因为是进行全文内容过滤，此功能会对服务器资源造成一定压力。


如何对帐号实行网站过滤及注意事项

首先，通过"帐号"->"网站过滤"来定义不同的"网站过滤"规则。
然后选择需要进行"网站过滤"的客户端的帐号，编辑该帐号，在"网站过滤"里选择先前定义好的"网站过滤"规则。
注意: "站点过滤"中的"允许站点"仅适用于结构简单的站点，不大适用于诸如163、sina等站点，因为此类站点结构比较复杂，页面中有些图片等信息来自于其他站点，会造成页面显示不全等问题。


时间安排的说明

控制客户端上网时间由"时间安排"功能来实现。
"时间安排"用来设置客户端的上网时段。
"帐号" -> "时间安排"：定义不同的时间安排规则。

"时间安排名": 可以输入不同的时间安排名，来标识不同的时间安排。此标识名将用于每个用户的帐号设置里。
"星期天"至"星期六": 用来设置不同工作日的上网时间安排。
可以直接在编辑框里设置时间，时间段用"起始时间-终止时间"来表示，不同时间段之间用"+"连接。如07:30-11:30+13:30-17:30，表示上午7:30至11：30分和下午1:30分至5:30分的时段内可以上网。
也可以点击编辑框旁边的按钮，弹出"时间表"对话框，可以用来设定相应工作日的时间安排。
"时间表"里有24个时间选择，表示不同的时间段。如选择"01:00"，表示00:00至01:00可以上网。
"应用于"表示该时段的时间控制只对所选的服务有效。


如何对帐号进行时间控制

首先，通过"帐号"->"时间安排"来定义不同的"时间安排"规则。
然后选择需要进行时间控制的客户端的帐号，编辑该帐号，在"时间安排"里选择先前定义好的"时间安排"规则。


如何使用自动扫描获取所有客户端的机器名、IP地址和MAC地址

管理员先打开所有的客户端机器，"帐号"->"自动扫描"，输入起始IP地址和结束IP地址，然后单击"开始"，可以自动获取局域网里所有客户端机器的IP地址、MAC地址和机器名。


为什么无法获取客户端的MAC地址

这种情况一般有以下三种原因:
1) 服务器或者客户端屏蔽了137端口，CCProxy扫描客户端MAC地址需要用到137端口发送UDP数据包;
2) 局域网网络环境不好或者网络繁忙，网络堵塞也会导致部分MAC地址扫描不到;
3) 客户端没有安装NetBIOS协议.
解决办法：
1) 关闭和服务器和客户端的防火墙或杀毒软件，开放137端口;
2) 修改cproxy.ini中TimeoutMAC=的值, 默认是200, 可改为1000, 表示扫描时间为1秒;
3) 客户端安装NetBIOS协议。


如何向客户端发送信息

客户端如果是Win98，要求已经运行了windows目录下的WINPOPUP.EXE。如果是Win2000/NT，则系统已经自带了消息接收功能。
在帐号管理里点击右键，在上面的编辑框里输入对方机器名，下面的编辑框里输入要发送的文字，点击确定就可以发送信息到客户端了。如果上面的对话框里输入的是"*"号，可以发送到局域网里的任何一台机器。


如何实现对域和域帐号的支持

CCProxy支持用本地或者局域网域服务器的帐号作为用户名/密码验证帐号。
ccproxy.ini中参数NTDomain=. 默认为CCProxy软件所在服务器的域，可改为局域网中其它域名称;
ccproxy.ini中参数NTUserAuth=0改为1，即可实现对域帐号的支持。
注意:
1) 启用此服务时，不可启用域帐号中的guest帐号,否则会造成所有用户都可以上网;
2) 启用此服务时，仅适用于WWW和SOCKS5服务身份验证;
3) 如果要对某帐号进行"网站过滤"、"时间安排"等服务，须在帐号中建一个与之相同用户名和密码的帐号，然后对新建的帐号进行管理。


如何让用户在不同的时间段内上不同的网站

可以为该用户建立不同的帐号，并为每个帐号设置不同的"时间安排"和"网站过滤"规则,即可实现对该用户进行分时管理。
比如：允许甲用户在8:00-10:00时间段内，只能访问新浪网站，在11:00-12:00时间段内,只能访问雅虎网站，那么可以进行如下操作:
1) 建二条"网站过滤"规则，分别为"只允许访问新浪网站"和"只允许访问雅虎网站";
2) 建二条分别为8:00-10:00和11:00-12:00的"时间安排"规则，并"应用于"WWW服务;
3) 为该用户在帐号中新建两个不同帐号，并为其设置好相应的"时间安排"和"网站过滤"就可以实现分时管理。


如何让用户在上班时间只允许收发邮件,下班时间既可以收发邮件又可以浏览网页等其他功能

假设用户NEC在7:00-11:30和13:30-17:30之间只允许收发邮件，其它时间既可以收发邮件又可以浏览网页等其他功能。
我们分析这个需求不难发现这样的规律：客户端收发邮件是不受时间限制的，也就是说我们只需要对邮件代理以外的其他服务进行时间管理。那么可以进行如下操作:
1) "帐号"—"时间安排"，建一条规则time1，然后分别点击"星期日"至"星期六"后面的"…"按扭，设置好相应的时间段，"应用于"里不选择"邮件";
2) 编辑"NEC"帐号，在"时间安排"前面打勾，并选择"time1"规则即可。

当然我们也可以这样做，为该用户建立两个帐号。
1) 一个帐号只开放邮件代理服务，设置时间规则为任何时间都运行上网（实际上可以不选择时间规则）;
2) 另一个帐号只开放除邮件服务以外的服务器，设置时间规则：00:00-7:30，11:30-13:30和17:30-24:00可以上网。


用户通过web方式发送邮件时如何禁止发送附件

在"内容过滤"里加入";; filename="。(注意: 有两个分号，在在第二个分号后面有一空格，如果有其余过滤的内容如chat等，此过滤内容必须放在第一位)


如何限制用户使用QQ

ccproxy.ini里将Socks5UDP=1改为SOCKS5UDP=0。所有客户端都不能用QQ了。
如果只想屏蔽某个客户端不能上QQ，不要修改上述参数，只需建一条网站过滤规则，禁止站点为客户机的IP地址。


如何限制用户使用二级代理

启动帐号管理，编辑该用户的帐号属性，将最大连接数设置成5，带宽设为4096字节/秒，同时将ccproxy.ini里的MaxConnectionMode=1改为MaxConnectionMode=0就可以了。此方法可以有效的阻止客户端开通二级代理，因为只分配了5个连接给此用户，如果他为其他用户开通二级代理，会影响其自身的上网状况。


如何限制客户端使用网络蚂蚁等工具下载

启动帐号管理，编辑该用户的帐号属性，将最大连接数设置成5，带宽设为4096字节/秒，同时将ccproxy.ini里的MaxConnectionMode=1改为MaxConnectionMode=0就可以了。此方法可以有效的阻止客户端使用下载工具，因为只分配了5个连接给此用户，如果他使用下载工具，会影响其自身的上网状况。


如何导入和导入帐号信息

"帐号"->"导出"，即可把当前的所有的用户信息保存起来;
"帐号"->"导入"，即可把原来的用户信息导入当前系统。


如何使用流量统计

1) 在CCProxy的"设置"—"高级"—"日志"—"运行流量统计"前面打勾，并设定"流量统计间隔时间"(默认为10分钟)，这样系统会在log文件夹中生成一个文件(如data20030613.txt)，并每隔10分钟系统在该文件中写入一次流量统计数据;
2) 点击"流量统计"，即可打开流量统计文件，观察到流量记录(前面的为流进数据,后面的为流出数据);
3) 还可以到主页上下载CCReport插件，可以根据统计出的流量，计算出每用户的使用费用。


如何使用帐号的排序功能

在"帐号管理"中，双击"IP地址"字样，所有帐号会按照IP地址大小的依次排列。同理，帐号也可以按照用户名、MAC地址或连接数的大小次序排列。选择"确定"后，帐号将按照排序结果保存。


如何简单有效的防止局域网外部用户使用代理服务

在"设置"->"高级"->"其他": "禁止局域网外部用户"前面打勾。这样可有效防止局域网外部用户利用您的服务器发送垃圾邮件，以及未经许可通过您的服务器代理上网。


拨号服务

CCProxy的拨号服务支持远程拨号、自动拨号、拨号空闲自动断开功能。

远程拨号
1) 在服务器上手工建立一个拨号连接，并且测试一下这个拨号连接是否有效。
2) "设置"：选择"远程拨号"。
3) "设置" -> "高级" -> "拨号"：在 "拨号列表" 中选择 1)中建立的拨号连接。在 "拨号用户名", "拨号密码" 里填上正确的上网帐号信息。
4) 客户端的IE要先设置好HTTP代理。
客户端访问 http://ccproxy.connect 就是可以拨号了，如果客户端用 http://ccproxy.connect.电话号码.用户名.密码 ，则用指定的电话号码和用户信息拨号。
5) 断开网络连接用 http://ccproxy.disconnect

自动拨号：访问网站时，如果没有拨号，代理服务器可以实现自动拨号。
1) "设置": 选择"远程拨号"。
2) "设置" -> "高级" -> "拨号"：选择"允许自动拨号"。然后在相应的代理协议前打勾，可以实现相应协议的自动拨号功能。

拨号空闲自动断开：当拨号上网闲置了一段时间，代理服务器可以自动断开拨号。
1) "设置": 选择"远程拨号"。
2)"设置" -> "高级" -> "拨号"：选择"拨号空闲断开时间"，在编辑框里可以输入空闲断开的时间。


网页缓存

网页缓存可以将访问过的网页保存在缓存里，在一定时间内，如果客户访问同一网页时，可以直接从缓存里获取，这样可以加快上网速度。 CCProxy的网页缓存是基于IE的缓存技术，共享了服务器的IE缓存文件系统。所以要求服务器安装IE 4.0或者以上版本。
1) "设置": 选择"网页缓存"
2) "设置" -> "高级" -> "缓存"：
"总是从缓存里读取"：表示缓存不更新，代理服务器总是从IE的缓存中获取网页数据。这个功能主要用于客户端下线浏览网页。
"缓存更新时间": 用来设置缓存的更新时间，时间设置越长，缓存里的数据保存越久。
"IE缓存选项":因为CCProxy的缓存共用了IE的缓存，所以缓存的目录和缓存的大小需要通过IE来改变。点击这个按钮，会自动弹出IE的Internet属性对话框，在"Internet临时文件"部分，点击"设置"按钮，就可以修改缓存的目录和大小了。


二级代理

二级代理是指服务器不能直接上网，必须通过其他代理服务器上网(如果是通过网关上网，仍然属于一级代理)。
1) 在使用二级代理前，先要弄清楚上级代理服务器的地址，开放协议和端口，以及是否需要身份认证。
2) "设置"->"高级"->"二级代理"：选择"启用二级代理"，在代理地址中输入上级代理服务器IP或计算机名称，选择代理协议HTTP/HTTPS/SOCKS，再输入对应的端口。若需要验证密码，则选择"需要验证"，在"用户名"、"密码"框中分别输入指定信息。

注意事项:
1) 若上级提供了SOCKS5服务，则可以为下级提供包括HTTP/FTP/GOPHER/SOCKS/RTSP/MMS/TELNET等协议在内的几乎任何服务，本程序可以全部自动转换；若上级提供了HTTPS服务，则绝大部分服务也可为下级提供，除了QQ/PP等UDP协议；若上级只提供了HTTP服务，则下级只能使用HTTP/FTP/GOPHER协议。
2) 6.0版支持不同的协议可以设置不同的二级代理或者不使用二级代理，即每一个协议都可以使用不同的上级代理和不同的协议或者部分协议使用上级代理，而部分协议可以不使用上级代理，也可以全部使用同一个上级代理和协议。


日志管理

CCProxy的日志管理分为在线监视和日志文件。

在线监视
可以观察当前用户的活动。双击界面上的绿色网格，可以看到监视当前的用户连接状态。

日志文件
"设置" -> "高级" -> "日志"：
选择"保存日志文件至"，可以将日志事件保存到日志文件里。
"日志事件选项": 日志事件除了记录最基本的时间，用户名，IP地址和访问类型外，还可以记录更详细的信息：
"访问网址" - 记录用户通过浏览器访问的站点
"图片信息" - 可以记录用户访问的图象信息，如果不选择此项，将在日志里屏蔽gif,bmp,jpg等图片访问信息。


管理员密码设置

"设置" -> "高级" -> "其他"，选择"密码保护"，输入相应的密码就可以了。选择"启动时需要密码"，则启动CCProxy时也需要输入登录密码。


其他设置

"本地IP地址"的说明:
"设置" -> "本地IP地址"，是指服务器上与局域网机器连接时所绑定的IP地址。
如果是"单网卡+拨号"或者"单网卡连接局域网+单网卡连接互联网"，可以自动检测出本地IP地址。
其他的需要取消"自动检测"，从网卡列表中选择一个服务器绑定的本地IP地址。

"NT服务":
"设置" ->"NT服务"：NT服务只对NT4.0，Win2000，WinXP和Win2003有效。选用NT服务后，可以让CCProxy在未登录状态下工作。

"设置" -> "高级" -> "其他"
"检测互联网连接状态的站点": 主要用来判断本地服务器是否与互联网是否连通，不同站点用分号分隔。
"连接闲置断开时间": 用来设置客户端连接代理服务器的闲置的自动断开时间。
"禁止局域网外部用户": 用来阻止互联网上其他用户使用本代理服务器上网。
"自动扫描机器名": 用来设置"自动扫描"时是否获取局域网内的机器名。
"开放SOCKS4": 用来设置SOCKS代理服务是否支持SOCKS v4.


常见问题解答及信息反馈

我们在主页上定期更新常见问题解答，如果您有什么问题和建议，欢迎您通过电子邮件反馈到 support@youngzsoft.com，或者发布在遥志软件论坛 http://www.youngzsoft.com/php。


联系方法

北京新世纪遥志软件开发有限公司

公司主页: http://www.youngzsoft.com/cn/
电子邮件: support@youngzsoft.com
用户论坛: http://bbs.youngzsoft.com/
购买方法: http://www.youngzsoft.com/cn/user.htm
电话号码: 010-82613296 010-82613926（电话号码以公布在主页上的为准）
传真号码: 010-82613926
公司地址: 北京市海淀区西苑操场5号畅春园饭店1-306
邮政编码: 100080


CCProxy, YoungZSoft 2000-2003